Ongoing power outage in Amsterdam
Resolved
May 30, 2025 06:38 UTC
Incident Updates
-
Resolved 1 year ago · May 31, 2025 12:55 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved 1 year ago · May 30, 2025 13:01 UTC
We've fixed the core issue, and are waiting for things to recover.
-
Resolved 1 year ago · May 30, 2025 06:38 UTC
Power interruptions from a third party supplier. The issue may be related to the underlying node: ams1-kvm1.my-hosting-panel.com, which appears to be down. Our infrastructure team is actively investigating and working on resolving the issue as a top priority. If you need any assistance in the immediate, [please reach out to our support team.](https://mochahost.com/support)